关于ACM问题

问题如下:

Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

 


   

Input

The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

 


   

Output

Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.

 


   

Sample Input

A B C D F
B F F C C A
D C E F

 


   

Sample Output

2.00
1.83
Unknown letter grade in input

代码如下:
   

#include<stdio.h>

#include<stdlib.h>

#include<string.h>


int main()

{ char     a[1000];

float    sum;

int      count,flag;

while(gets(a))

  {

flag=1;

count=sum=0;

for(int i=0;i<strlen(a);i+=2)

            {

                   if(a[i]=='E')

                      {

                        flag=0;

                        break;

                    }

               else

                    {

                      if(a[i]=='A')

                            {

                                sum+=4;

                                count++;

                           } 

                    else if(a[i]=='B')

                           {

                               sum+=3;

                               count++;

                        }

                         else if(a[i]=='C')

                            {

                               sum+=2;

                               count++;

                                 }

                                else if(a[i]=='D')

                                        {

                                           sum+=1;

                                             count++;

                                          }

                                       else if(a[i]=='F')

                                               {

                                                  count++;

                                                  }

                                             }

                    }

                                             if(flag==1)

                                                  printf("%.2f\n",sum/count);

                                             else

                                                   printf("Unknown letter grade in input\n");

          }

          system("pause");

           return 0;

}

在编译软件上测试时对的,但提交上去确实WA。不知道错在哪,求指教

qq_新生_10
浏览 1040回答 0
0回答

慕设计2395807

LHKDXWAUGUDKJPNMMWCVYLPVBBBCVIEEMRZIWWBEOPJZHCVEOOXVYOINKTKASHNERXFBRXXLSYBSYZZPJSAGMGPPQDMMXRREBLEVPYILOLRUUTRBQGLRAQQUDXNGNMYHNUNQBOXNSIYSVLBEUQHLOQGJBHCCOOZWZUXKKOOBACFIOEYEMVVLLKCVYHRWAVVRLXEVRRUDAOBBSSCCBJMRYKANTJJSPCPPBLOKEUEQVBKREHTXXDDXZTMMCCBLLVUKKQHQNUUNGWFPLISYBJGEMOOEOXQNNTWJGFIVBRJZCEAGATRHHUQQIGWMISIBISLWNMTICHEXHHTWFFIYBYOZCUDWNKDCUNGGMZSSYYBRUNDSKZFDNMMCWWGDWFPSVYEEMBSVYUKKXQQARXXXQDWSWMCQXQRAQGGJZPXAHXHDOVPFFBUDRUQQGPGFCVYKXTCCTDCEODYONKHXQTJPYOOOPNNNWUQDDPMIIFLLUQZCLBRNDEUBRNDNJFTDTWHDGPYBJEUQTUKTILIKGJGVCLHXNOKTDTIHJSVLNDMWYOFADGWGIEUKGGPRUDRHENDTISSPZVFBEUDQFHRILNXMWSUWLOQHRGWGPKMOEHDAJZHEYHDGCYHXNWGQLKDQGCVFFYWYHXGJMJLUKUORHWMIRHKAMOSBRUQZIRBFODNQTCFVEUCLHYNXAJFNDUQSBEADMPFINQKSCMILEUEBYNQMJZNPSVMCRHWMPSAEMWEORUXNWZOEAJXNQLOLGWTUQTCQGQMIENEYPYOQTPLUKLHDTQAVXGCLUDZDRALUDTVXMCLVRUSVEUIZHXNDGJZPSUKSVSVSIDNJKZISFIICPWGOKHWSWFUKFBUQZIZCZHWSPUJFPSPKUBEA
打开App,查看更多内容
随时随地看视频慕课网APP