poj1936题我为什么一直是Time Limit Exceeded

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output

Yes
No
Yes
No
我的程序:
#include<iostream>
#include<cstring>
using namespace std;
int main(){
char sourcestr[100001],substr[100001];
while(cin>>substr>>sourcestr){
int i=0,k=0;
for(;i<strlen(substr);i++){
for(;k<strlen(sourcestr);k++){
if(*(substr+i)==*(sourcestr+k)){
if(i<strlen(substr)-1)
    break;
        else if(i==strlen(substr)-1)
        cout<<"Yes"<<endl;}} if(k==strlen(sourcestr)&&*(substr+i)!=*(sourcestr+k)){
        cout<<"No"<<endl;
        break;}
}
memset(sourcestr,0,100001);
memset(substr,0,100001);
}
return 0;}

qq_我是谁_45
浏览 1161回答 1
1回答
打开App,查看更多内容
随时随地看视频慕课网APP