手记
下载APP
继续浏览精彩内容
慕课网APP
程序员的梦工厂
继续

php composer.phar install 报错

会当凌绝顶聪明
关注TA
已关注
手记 207
粉丝 35
获赞 72

在使用php composer.phar install 时报的错误

mongodb/mongodb 1.0.0 requires ext-mongodb ^1.1.0 -> the requested PHP extension mongodb is missing from your system.

这个问题的大致意思是mongodb1.00需要扩展驱动mongo 1.10,问题原因可能是:

  1. mongodb和mongodb的驱动扩展版本不兼容

  2. php 扩展中缺失了其中的一个扩展(我遇到的为题就是这个,有mongo扩展,没有安装mongodb扩展)

安装相应的扩展包即可解决,扩展包地址:

https://pecl.php.net/package/mongo

https://pecl.php.net/package/mongodb

打开App,阅读手记
0人推荐
随时随地看视频慕课网APP