继续浏览精彩内容
慕课网APP
程序员的梦工厂
打开
继续
感谢您的支持,我会继续努力的
赞赏金额会直接到老师账户
将二维码发送给自己后长按识别
微信支付
支付宝支付

pie(二分查找)

慕田峪9129951
关注TA
已关注
手记 337
粉丝 200
获赞 993

PieCrawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
  

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
  

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3). 

Sample Input

33 34 3 31 24510 51 4 2 3 4 5 6 5 4 2

 

Sample Output

25.13273.141650.2655

ps:纠结了好久,一直看不懂题意,太菜了,真心纠结!!!现在才弄懂!!!各位大神必须弄懂题意啊!!!真的很重要!!!顺便说一下重敲是个好东西,信重敲得永生!还有double型的精度。密切注意!

# include <stdio.h>
# include <stdlib.h>
const double PI = 3.1415926535897932;
int main()
{
    int t, n, f;
    double r[10010];
    scanf("%d",&t);
    while(t--)
{
        scanf("%d%d", &n,&f);
        f++;                            
        double sum = 0;
        for(int i = 1; i <= n; i ++)
{
            int x;
            scanf("%d",&x);
            r[i]=x*x;
            sum += r[i];
        }
        double mid,l=0, h;
        h=sum/f;
        while(h-l> 1e-6)
{
            mid = (l+h)/2;
            int num = 0;               
            for(int i = 1; i <= n; i ++)
                num += (int)(r[i] /mid); 
            if(num >= f) l=mid;
            else h= mid;
        }
        printf("%.4lf\n",mid*PI);
    }
}
 

打开App,阅读手记
0人推荐
发表评论
随时随地看视频慕课网APP