猿问
下载APP

webpack4配置设计babel的问题

如题。安装了

"babel-core": "^6.26.3",

"babel-loader": "^8.0.4",

"babel-plugin-transform-runtime": "^6.23.0",

"babel-preset-env": "^1.7.0",

"babel-preset-stage-0": "^6.24.1",

运行报错:

Cannot find module '@babel/core'

 babel-loader@8 requires Babel 7.x (the package '@babel/core'). If you'd like to use Babel 6.x ('babel-core'), you should install 'babel-loader@7'.

请问,这个问题怎么解决啊

秋叶冰糖葫芦五加皮
浏览 916回答 2
2回答

八神光

安装7.x版本的babel-loader或者安装7.x版本的babel-core报错里告诉你了 8.x版本的babel-loader配7.x版本的babel-core,而7.x版本的babel-loader配6.x版本的babel-core

_Bling_

注意:@babel/core,现在安装新版babel时貌似都要这样写,而不是babel-core。应该时这样可以试下。
打开App,查看更多内容
随时随地看视频慕课网APP
我要回答