猿问
下载APP

swift 包管理怎么用

请教一下,swift包管理怎么用?我创建了一个swift项目,然后在根目录创建了一个Package.swift文件,
代码如下:

import PackageDescriptionlet package = Package(
    name: "Format",
    dependencies: [
        .Package(url: "https://github.com/marmelroy/Format.git", majorVersion: 1),
    ]
)

但是这里“ PackageDescription”报错,系统提示没有这个库,使用swift build也无效。
https://img3.mukewang.com/5b792b940001604607580199.jpg

这个是什么问题,请大神解答一下。


繁花不似锦
浏览 393回答 2
2回答

哆啦的时光机

swift package generate-xcodeproj 先生成xcode的工程文件。然后打开就可以了。

千万里不及你

首先我的理解是 SwiftPM (Swift Package Manager) 不是在 Xcode 里面这样使用的。而是直接在命令行里进行的。官方简介:The Swift Package Manager is a tool for managing the distribution of Swift code. It’s integrated with the Swift build system to automate the process of downloading, compiling, and linking dependencies.大概意思是, 你可以直接使用 SwiftPM 来进行 下载、编译、链接 你的 Swift 代码和依赖而在 OS X 上面安装的 Xcode 里面目前(Xcode 7.3)是没有带上 SwiftPM 这个工具的,所以当你执行 swift build 时会报错,如下:$ swift build error: unable to invoke subcommand: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/swift-build (No such file or directory)所以,你需要去下载开发版本的 swift。以下为解决方案:安装去官方下载 Swift Trunk Development (master) 版本(即 dev 版本, 与 Xcode 使用版本不冲突)。传送门下载下来应该是 swift-DEVELOPMENT-SNAPSHOT-2016-03-24-a-osx.pkg 这样一个文件 大约 200MB将最新的 Swift 版本配置到环境变量里。打开命令行执行$ export PATH=/Library/Developer/Toolchains/swift-latest.xctoolchain/usr/bin:"${PATH}"然后检查是否安装成功$ swift build --versionApple Swift Package Manager 0.1使用首先,创建一个空目录$ cd ~/Desktop $ mkdir helloSwiftPM  $ cd helloSwiftPM然后,初始化这个目录。$ swift build --init编译$ swift build运行$ .build/debug/helloSwiftPMHello, world!到此就 OK 了 ?参考:官网 Getting Started官网 Swift Package Manager Swift.gg 使用 SwiftPM 创建新的包
打开App,查看更多内容
随时随地看视频慕课网APP
我要回答